jobiri.com upgrade
Incident Report for Jobiri
Resolved
This incident has been resolved.
Posted Apr 03, 2021 - 21:10 UTC
Update
We are continuing to investigate this issue.
Posted Apr 03, 2021 - 21:10 UTC
Investigating
Upgrade of the website www.jobiri.com
Posted Apr 03, 2021 - 21:10 UTC
This incident affected: JOBIRI.COM WEBSITE.